MySQL【表空间迁移大表】
0. 目标端必须有同名表,没有则建一个空表; #################################### 1、 源端文件准备 源端: flush tables t for export; 复制 t.ibd, t.cfg到目标端。 ############################### flush tables tt7 for export; cp tt7*...
View ArticleREDIS5.05哨兵模式主从自动切换环境搭建和快速脚本调试
1、 安装redis包 ############################################################################ 、、下载 包 redis-5.0.5.tar.gz cd /usr/local/redis5/redis-5.0.5 make make install...
View ArticlemysqlRouter与MySQL集群结合实现读写分离
、、安装mysql Router ====================================================================================================== [root@vm701 111]# rpm -ivh mysql-router-community-8.0.15-1.el7.x86_64.rpm...
View ArticleINNODBMGR错误排查与解决日志
[root@vm706 mysql-proxy]# cd bin [root@vm706 bin]# ll total 44 -rwxr-xr-x 1 root root 9696 Dec 17 2014 encrypt -rwxr-xr-x 1 root root 23564 Dec 17 2014 mysql-proxy -rwxr-xr-x 1 root root 1552 Dec...
View ArticleZABBIX基本安装
http://www.zabbix.com/download.php? wget https://fossies.org/linux/misc/zabbix-4.0.5.tar.gz/ 0. hostnamectl --transient set-hostname vm711 hostnamectl --static set-hostname vm711 192.168.1.118 vm708...
View ArticleYUM的扫盲笔记
============================= yum ========================================== yum 是什么 简称黄狗,Yum(全称为 Yellow dog Updater,...
View ArticleREDIS集群自动启动服务脚本
自动启动(一次性) cat /etc/rc.d/rc.local add to 服务型脚本添加 ====================== 、、添加服务脚本(star/stop) 、、1 cd /etc/init.d vi redisd 脚本 内容........................... 、、2 chkconfig --add redisd...
View ArticleCassandra--管理命令
================================================================ cluster 节点管理 ================================================================ 、、、1 ##安全启动与关闭 =========================== 启动 -------- cd...
View ArticleFailedtostartLSB:Bringup/downnetworking.解决方法
====================== Failed to start LSB: Bring up/down networking. ===================== Failed to start LSB: Bring up/down networking.解决方法 systemctl status network : network.service - LSB:...
View ArticleLinuxcentos手记6
禁用大内存页 ============================================================= 启用状态 [root@vm701 ~]# cat /sys/kernel/mm/transparent_hugepage/enabled [always] madvise never [root@vm701 ~]# [root@vm701 ~]# cat...
View ArticleSQL写法1
delimiter $$ create procedure tt() begin declare i int ; set i = 1; while i < 11 do insert into t (x) values ( i); set i = i +1; end while; end ; $$ delimiter $$ set @i = 1;...
View Article#################################################################
################################################################# #################################################################
View ArticleSQL写法举栗子
delimiter $$ create procedure tt() begin declare i int ; set i = 1; while i < 11 do insert into t (x) values ( i); set i = i +1; end while; end ; $$ delimiter $$ set @i = 1;...
View Articletable_open_cache修改变化与影响
、、、8 limits, mysqld.log里面参数告警 ------------------------------------- 2019-02-06T03:50:59.575027Z 0 [Warning] [MY-010139] [Server] Changed limits: max_open_files: 10000 (requested 10010)...
View Articlemysql57-增量恢复规范案例
0 准备目录 ================== mkdir -p /project0/ mkdir -p /project0/back1/ mkdir -p /project0/inc1 mkdir -p /project0/inc2 mkdir -p /project0/inc3 mkdir -p /project0/inc4 0 初始化数据...
View ArticleMYSQL主要参数设置***
################################################ 0、REDO日志和缓冲参数: ################################################ innodb_io_capacity = 200 innodb_log_file_size = 2000M innodb_log_files_in_group = 4...
View ArticleMySQL8.0-单机安装和重置密码的一些注意事项
[root@k8s1 opt]# ll total 96504 -rw-rw-rw- 1 root root 26712872 Dec 21 22:02 mysql-community-client-8.0.14-1.el7.x86_64.rpm -rw-rw-rw- 1 root root 579516 Dec 21 22:02...
View ArticleMySQL8.0-InnodbCLUSTER集群搭建过程CENTOS7
多少年来MySQL高可用方案一直是千千万mysql系统用户的心结和软肋; 多少自带或第三方的方案,都不能称为一个绝对、有效、好维护的高可用方案,需要不少人肉处理过程,如果是写很重要的系统,都有点底气不足心里不安的状态; M/S, MMM,MHA,NDB等,不是难以保证一致性,或是太过复杂,或是难以诊断问题; InnodbCLUSTER的出现基本上是解决以上大部分软肋的里程碑式的方案; 0、...
View ArticleCassandra数据中心名称错误导致KEYSPACE故障:NoHostAvailable
修改了数据中心名称导致KEYSPACE故障:NoHostAvailable 、、1 表可以显示,不能查询 [root@vm702 conf]# cqlsh 192.168.1.114 9042 Connected to CASSAN cls001 at 192.168.1.114:9042. [cqlsh 5.0.1 | Cassandra 3.11.3 | CQL spec 3.4.4 |...
View Article3.salt-stack安装gpfs4.1CENTOS7
centos7安装gpfs 4.1 一、节点准备 1、节点配置 hostname g0 matadata节点 g1 matadata节点 g2 matadata节点 g3 data节点 g4 data节点 g5 data节点 2、安装ntp yum install ntp -y service ntpd start systemctl enable ntpd 二、安装gpfs...
View Article